Maticový vzorec v Excelu

Co je to maticový vzorec

Jedná se o vzorec, který umožňuje pracovat s několika hodnotami současně. (Co je matice podle Wikipedie)

Příklad maticového vzorce

Pokud mám například následující řádek s hodnotami A,A,B,A…

  A B C D
1 A A B A

…chci vypočítat, kolikrát se v něm vyskytuje písmeno “A”…napíšu následující vzorec

{=SUMA(KDYŽ(A1:D1=”A”;1;0))}

Výsledkem KDYŽ(A1:D1=”A”;1;0) bude matice ~ několik hodnot 1,1,0,1, které se pomocí SUMA sečtou na výslednou hodnotu 3. Samotná buňka se vzorcem KDYŽ(A1:D1=”A”;1;0), který nebude zadaný jako maticový, vypíše chybu #HODNOTA!. Pokud se vzorec vloží jako maticový (Ctrl+Shift+Enter) v buňce se objeví hodnota 1 (první ze 4 hodnot) – pro zobrazení hodnoty na jiné pozici je potřeba provést zápis {=INDEX(KDYŽ(A1:D1=”A”;1;0);0;3)} (matice hodnot, řádek, sloupec)

Potvrzení maticového vzorce

Ctrl + Shift + Enter

Pozn.

klasický vzorec KDYŽ(A1=”A”;1;0) by vrátil výsledek jen pro konkrétní buňku, bez maticového vzorce by se tedy musel např. vytvořit pomocný řádek s výsledky pro jednotlivé buňky a ten následně sečíst.

Share
Příspěvek byl publikován v rubrice Nezařazené se štítky . Můžete si uložit jeho odkaz mezi své oblíbené záložky.

Napsat komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *

*